Relationship Awareness (RA) degradation for PrecisionLender Clients in the United States

Incident Report for PrecisionLender.com

Resolved

After additional monitoring, services have been fully restored and everything looks good so far. Clients may now use RA processing as normal and existing RA jobs are processing as expected. We thank you for your patience throughout all of this. We're closing this incident as resolved and will continue monitoring closely.

If you have any questions, please contact PrecisionLender Support.
Posted Sep 10, 2025 - 16:06 EDT

Monitoring

We have identified the RA processing issues and are seeing services begin to restore. We will continue to monitor and will provide an update soon.
Posted Sep 10, 2025 - 14:12 EDT

Investigating

We are investigating an issue with uploading and processing Relationship Awareness (RA) file uploads today for clients located in the United States. RA uploads in progress and new RA upload attempts may fail to complete. We will provide an update as soon as more information is available.

And if you have any questions, please contact PrecisionLender Support.
Posted Sep 10, 2025 - 13:22 EDT
This incident affected: Relationship Awareness Processing.